
 

 

 

RoboPrint User Guide 

 
 

In order to 3D print a model on your Robo printer, you must 

first run it through a slicing software such as RoboPrint or 

RoboCloud (our online version) so that the printer knows how 

to read the file. This guide will walk you through how to do so 

in RoboPrint 5.  

 

Updated February 2024 

 
Updates to the software may have occurred since the creation of this document. Variations 

may occur between models of 3D printers with what shows in the program.  
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User Guide 

1. Software Introduction 

Boxlight’s RoboPrint 5 is newly revised and upgraded. Through new interface design and function 

optimization, the operation is simple and convenient. The slicing file will be prepared by just a 

few clicks with fast, efficient, and smooth operation. 

2. Software Installation 

Open the browser and enter https://robo3d.com/pages/desktop-software. Download the latest 

version of RoboPrint 5.                                                                                                

3. Software Operation 

Users can control the operation of the printer through the RoboPrint software. 

 

 

  

View the model from different angles. 

    

 

Click it to move the model along X,Y axis, Shift+ mouse click it to move along Z axis. 

    

 

Rotate the model. 

https://robo3d.com/pages/desktop-software
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Scale the model size. 

 

 

Cut the model from different directions. 

 

 

Copy the selected model file. 

 

 

Automatically arrange all models. 

 

 

Enter the support editing mode. 

 

 

Enter the wiping tower editing mode. 

 
Enter the multi-machine control interface (only compatible with certain models). 

 
Enter the machine connection interface. 

 

Enter the model file list, where you can display, load and delete the model file. 

 

Select the machine type, nozzle size and printing mode. 

 
Enter the slicing parameter editing interface. 
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3.1 Load Files 

Users can load files into RoboPrint in the following ways. 

◆ Method 1: Click the "Load" icon 

in the “Model File” list and 

select the file to be loaded after 

a dialog box pops up;  

◆ Method 2: Click "File->Load File" 

in the menu bar and select the file to be loaded after a dialog box pops up; 

◆ Method 3: Drag the file to be loaded to the main interface of the software; 

◆ Method 4: Click the "File-> Examples" in the menu bar to load the files in the list; 

◆ Method 5: Click the "File-> Recent Files" in the menu bar to load the files opened in the 

latest period of time in the file list; 

◆ Method 6: Drag the file to be loaded onto the software icon. 

The software currently supports slc, stl, obj, fpp, png, jpg, jpeg, bmp, 3mf format files that can be 

edited in the software. After loading the model file, if you need to edit the model, you can refer 

to Section 3.1 to 3.5 (these sections provide detailed information on mouse action, scene view 

change, model editing and saving, etc). After the model adjustment is completed, the user can 

slice the model into a Gcode file and print it (please refer to Section 3.8 for details). 

The Gcode file is a print file of the model and cannot be modified. But it can be directly used for 

printing after loading (please refer to Section 3.6.1 and Section 3.6.2.2 for details). 

 

 

3.1.1 Generate From Image 

You can generate relief models from the following image formats: png, jpg, jpeg and bmp. That 

is, convert the png, jpg, jpeg and bmp format files into the stl format files and load them into the 

software for use. 

Load files in the png, jpg, jpeg, bmp format using the same methods listed above. The "Convert 

image to stl" window will pop up. From this pop up you can adjust the following parameters: 

Shape: It includes six shapes: plane, sphere, tube, canister, lamp(shade), and seal.  

Mode: It is divided into "Darker is thicker" mode and "Lighter is thicker" mode.  

Maximum Thickness: It converts to the Z value corresponding to stl. 
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Base Thickness: It is the minimum thickness of the bottom of the generated stl and the default 

value is 0.5mm.  

Width: It converts to the X value corresponding to stl. 

Depth: It converts to the Y value corresponding to stl. 

Back Cover Thickness: It is for the thickness of the back cover of the canister and lampshade.  

Top Diameter: It is for the top diameter of the tube, canister and lampshade.  

Bottom Diameter: It is for the bottom diameter of the tube, canister and lampshade. 

Pattern Thickness: It is the maximum thickness of the seal surface pattern (only applicable to 

seals).     

Equatorial Diameter: It is the spherical equatorial diameter (inner diameter) size.   

Allowable Ellipsoid: It includes 'Yes' and 'No' options. Select 'Yes' to generate the corresponding 

ellipsoid according to the scale of the loaded picture (the diameter of the two poles depends on 

the scale of the loaded picture); Select 'No' to generate the sphere according to the loaded 

picture. 

Parameter Window: 
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The original png picture is shown to the 

right. The effects of the converted stl 

format files after selecting different 

'Shape(s)' in the parameter window are 

pictured below. This process can be 

used for images like the example but is 

best for images designed for this, such 

as black and white displacement maps.  

   

Plane: Generates the image based on darkness. Sphere: Translates the image around a sphere. 

     

Tube: Translates the image around a tube. The tube is hollow on both ends. Top and bottom 

diameter can be adjusted as shown here. 
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Cannister (left) & Lamp (right): Both cannister and lamp(shade) fill in one side of the image. 

Cannister fills in the bottom of the tube to make something like a vase. Lamp fills in the top of the 

tube and then rotates the tube 180° so the filled in edge is on the bottom for better printing.  

Both cannister and lamp can be adjusted to taper like we showed with the tube. 

  

Seal: Creates a mirror image of the provided image so you can stamp it onto another surface. 

 

3.2 Mouse Action 

3.2.1 Left Click 

◆ You can select the current model by left-clicking it. 

◆ You can select multiple models by holding the Ctrl key and then left-clicking models you 

want. 
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◆ The selected models will appear in brighter colors. 

◆ After the models are selected, you can edit the selected models. 

◆ Click on the blank space to release all the selected models. 

3.2.2 Hold Left Mouse Button 

When the Ctrl key is pressed, the function of selecting models with the left mouse button is 

realized. When changing the view or editing the model, the use effect of the left button is 

different. (please refer to Section 3.3.1 to 3.3.2 and Section 3.4 for details) 

3.2.3 Right Click 

Right-click will bring up a multi-function menu with the following menu functions: 

◆ Center Selected Models; 

◆ Delete Selected Models; 

◆ Copy Selected Models; 

◆ Select All Models; 

◆ Clear Platform(the build plate); 

◆ Bind(ing) Models; 

◆ Unbind(ing) Models; 

◆ Align Models. 

3.2.4 Hold Right Mouse Button 

In any operating state, the use effect of the right mouse button is the same. (please refer to 

Section 3.3.1 to 3.3.2 for details) 

3.2.5 Scroll Mouse Wheel 

In any operating state, the use effect of the mouse wheel is the same. (please refer to 

Section 3.3.3 for details) 

 

3.3 Scene View Change 

You can choose the perspective view or orthogonal view, and you can make changes to the scene 

view, including dragging the scene, rotating the scene, scaling the scene and so on. 
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3.3.1 Drag 

The model in the print range can be dragged around the screen in the following three ways: 

◆ Method 1: Long press the left mouse button and drag the mouse; 

◆ Method 2: Hold the middle mouse button and drag the mouse; 

◆ Method 3: Hold the Shift key, then long press the right mouse button and drag the 

mouse. 

3.3.2 Rotate 

The scene view can be rotated in the following two ways: 

◆ Method 1: Long press the right mouse button and drag the mouse; 

◆ Method 2: Hold the Shift key, then long press the left mouse button and drag the 

mouse. 

3.3.3 Scale 

In any operating state, you can change the observation distance of the model by scrolling 

the mouse wheel or using the '+/-' shortcut key. 

3.3.4 Set 

In the following three ways, the model can be observed from six directions: top view, 

bottom view, front view, back view, left view and right view. 

◆ Method 1: Click the "View" button in the menu bar, and you can choose to observe the 

model from six directions; 

◆ Method 2: Select the "View" button on the right side, and then click the button again, 

and a view selection box will pop up, from which you can select views in six directions; 

◆ Method 3: Select the build plate border and double-click it for view switches. 

3.3.5 Reset 

Click the "View" button in the menu bar and select "Home View". 

 

3.3.6 Model Outline Display 

Click the "View->Show Model Outline" in the menu bar, and the model outline will be 

displayed. 
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3.3.7 Steep Surface Display  

Click the "View->Show Steep Overhang->Enable/Disable" in 

the menu bar, if the horizontal angle of the model surface is 

within the steep overhang threshold value, then this part of 

the surface belongs to the steep overhang surface and the 

color changes to red. The steep overhang threshold value 

can be set as required, and the default value is 45 degrees. 

  

 

3.4 Edit Models  

You can edit the models, including moving, rotating and scaling the models and so on. 

3.4.1 Move 

After selecting the model to be moved with the left mouse button, the spatial position of 

the model can be adjusted by the following two movement methods: 

◆ Method 1: After selecting the "Move" button on the right side, if you press and hold 

the left mouse button and move the mouse, you can move the model in the XY plane. If 

you hold the Shift key, press and hold the left mouse button and move the mouse at 

the same time, you can move the model in the Z direction. In the process of moving, 

you can see the distance and direction of the movement, which are used to indicate the 

displacement of the model relative to the previous position. 

◆ Method 2: Select the "Move" button on the right side, then click it again, a Position 

Setting box will pop up, where you can adjust or set the position of the model, or reset 

the model position.  
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Note: Generally, after the model position adjustment is 

completed, you need to click the "Center" and "On 

Platform" buttons to ensure that the model is within the 

print range and close to the build plate. If you need to 

arrange the printing position of the model specially, you 

can just click the "On Platform" button. 

To make sure your model is on the build plate, look from 

below it. Any surface area touching the build plate will 

show up in blue. 

 

3.4.2 Rotate 

3.4.2.1 Select the model to be rotated with the left mouse button, and adjust the 

placement posture of the model by the following rotation methods: 

◆ Method 1: After selecting the "Rotate" button on the right side, you will see three rings 

perpendicular to each other, which are red, green and blue. Click the selected ring to 

rotate around the current rotation axis (X, Y or Z direction optional). The turning angle 

and direction of rotation will be displayed at the center of the circle in the form of 

included angle.  

◆ Method 2: Select the "Rotate" button on the right side, then a Rotation Setting box will 

pop up, where you can adjust or set the rotation angle of the model, or reset the model 

posture. 

3.4.2.2 Surface to Platform 

      After selecting the model, please operate as below: 

◆ Select "Rotate->Surface to Platform"; 

◆ Select a certain surface of the model with the mouse, double-click the left mouse 

button on the suspended surface, and the model will be automatically placed according 

to the surface. Double-check that it lines up well by looking for the blue on the bottom. 

 

3.4.3 Scale 

After selecting the model to be scaled with the left mouse button, the size of the model can 

be adjusted by the following scaling methods: 

◆ Method 1: After selecting the "Scale" button on the right side, press and hold the left 

mouse button and drag the mouse to change the model size.  
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◆ Method 2: Select the "Scale" button on the right side, and then click the button again, 

and a Model Size Setting box will pop up, where you can set the size of the model or 

change the scale in each direction for scaling. 

In addition, if the "Uniform Scaling" option below is checked, changing the length of 

any side will make the model scale equally; If the "Uniform Scaling" option is 

unchecked, the length will be changed in a single direction. 

 

3.4.4 Cut 

After selecting the model with the left mouse button, select the "Cut" button on the 

right side and a Cutting Setting box will pop up (as shown below). Cutting settings are: 

cutting direction (hand-drawing, X plane, Y plane, Z plane), cutting position and “Keep parts 

in place”. 

 

Move the plane around until it is in the correct position and click the "Start Cut" button or 

double-click the model to cut the model. 

Keep parts in place: After cutting, the newly generated model remains in its original position and 

will not be moved away automatically. The version on the left below shows this option. 
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3.4.5 Others 

3.4.5.1 Undo 

The previous edit to the model can be undone in the following two ways: 

◆ Method 1: Click the "Edit->Undo" in the menu bar; 

◆ Method 2: Use the shortcut key Ctrl+Z.  

3.4.5.2 Redo 

The previous edit to the model can be redone in the following two ways: 

◆ Method 1: Click the "Edit->Redo" in the menu bar; 

◆ Method 2: Use the shortcut key Ctrl+Y.  

3.4.5.3 Empty Undo-Stack 

Clear the recorded operation steps in the undo stack and release the occupied memory. 

3.4.5.4 Select All  

All models can be selected in the following three ways. (If the models are too small or out of 

view, you can select all models in the scene and then use the "Center" and "Scale" functions 

to adjust the models.)  

◆ Method 1: Click the "Edit->Select All" in the menu bar; 

◆ Method 2: Use the shortcut key Ctrl+A; 

◆ Method 3: Click the right mouse button and select "Select All Models". 

3.4.5.5 Duplicate 

After the model is selected, you can create a copy of the corresponding model in the 

following three ways: 

◆ Method 1: Click the "Edit->Duplicate" in the menu bar; 

◆ Method 2: Use the shortcut keys Ctrl+C and Ctrl+V; 

◆ Method 3: Click the right mouse button and select "Copy Selected Models". 

3.4.5.6 Delete 

After the model is selected, you can delete the corresponding model in the following two 

ways: 
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◆ Method 1: Click the "Edit->Delete" in the menu bar; 

◆ Method 2: Use the shortcut key Del; 

3.4.5.7 Auto Placement 

After loading one or more models, click the "Auto Layout All" button on the right side and 

fill in the "Space Between Models" (range: 0-50mm). 

All models will be automatically placed according to the automatic placement rules. 

 

 

3.4.5.8 Mirror 

Click the "Edit->Mirror Models" to perform mirror operation to the selected models in the 

X-direction, Y-direction and Z-direction. 

3.4.5.9 Repair 

When a model is loaded, the model will be tested. 

When the model is detected with problems, a 

detection prompt will pop up to remind the user; At 

this time, you can directly click the "Repair Models" 

button in the pop-up dialog box or select the model 

and choose "Repair Models" in the "Edit" menu bar 

to repair the model.  

Models that come in with errors will have a red 

outline. 
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3.4.6.10 Wiping Tower 

After loading the model, click the "Edit->Wiping Tower" or click the "Wiping Tower" button 

on the right side to enter the wiping tower editing interface. 

A wiping tower is a method to ensure cleaner transitions between colors of models if you 

plan to manually change colors partway through a print. If you are not doing so, you may 

skip adding a wiping tower.  

 

The size, base size and shell 

thickness parameters of the wiping 

tower can be set in the wiping 

tower option setting. The wiping 

tower height can be set to be the 

same height as that of the loaded 

model by default; If there are 

multiple models, the height of the 

highest model is taken as the 

default.  

After setting the parameters of the wiping tower, click the "  or " 

button, move the mouse to select the coordinates of the wiping tower, and click the left 

mouse button to add the wiping tower.  

When you need to delete the wiping tower, click " " and select the wiping tower with 

the left mouse button to delete it. 
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3.5 Supports 

After loading the model, click the "Edit->Supports" in the menu bar or directly click the  

button on the right side to enter the support editing mode (as shown below). Click the "Back" 

button to exit the support editing mode after the support editing is finished. 

3.5.1 Auto Supports 

After clicking the "Auto Supports" button, the software will automatically determine where 

the model needs to be supported and generate the corresponding treelike or linear supports.  

   

You can adjust the Overhang Threshold higher or lower to add more or fewer supports 

automatically. You can also manually add and remove supports in this mode. See section 3.5.3 

and 3.5.4 below. For additional settings adjustments, see section 3.5.6. 

3.5.2 Clear Supports 

After clicking the "Clear Supports" button, all supports in the scene will be deleted. Click 

"Undo" in the menu bar or use the shortcut key Ctrl+Z to undo the operation. 

3.5.3 Add Supports 

When the "Add" button on the left side is selected, you can add supports. Move the mouse to 

the position where the model needs to be supported, and click the left mouse button to select 

the starting point of the support; Hold the left mouse button and drag the mouse to display the 

support preview (if the support surface does not need support or the angle of the support 

column is too large, the support preview will be highlighted); Release the left mouse button, and 

if the support column does not touch the model, the support will be generated at the starting 

and ending positions (the previewed support will be highlighted, but the support structure will 

not be generated). 
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Select "Show Model Slice Outline" in the "View" menu bar, and when the mouse pointer moves 

to the model, the corresponding model section outline will be displayed at the mouse position 

for better observation and selection of the supporting point position. 

For single selection, please click the mouse. 

Hold the “Ctrl” to select more. 

Hold the “Ctrl”to drag the box selection. 

For Mac version, please hold the “Command” key and drag the mouse to select support. 

 

3.5.4 Delete Supports 

When the "Remove" button on the left side is selected, the support can be deleted. Move the 

mouse to the support to be deleted, and the current support and its child node supports will be 

highlighted. Click the left mouse button to delete these highlighted supports. Ctrl+left mouse 

button can check the support to be deleted. 

 

3.5.5 Model Option 

When the "Add" and "Remove" buttons are both unchecked, only the selected model will be 

performed for the "Auto Supports" and "Clear Supports" operations. When there are multiple 

models, different support parameters can be selected to support different models. 

 

3.5.6 Supports Options 

Support parameters can be edited in the "Supports Options" box. Support types include tree and 

linear support. When " " is selected, parameter values of the tree support will appear: 

(Steep) Overhang Threshold (Angle), Post Diameter, Base Diameter, Base Height, and Touch 

Platform Only. Set the required support parameters according to the model, click the "Auto 

Supports", and the generated support will be displayed as a tree structure; When " " is 

selected, parameter values of the linear support (Steep Overhang Threshold Angle, Pillar size, 

Touch Platform Only) will appear. Set the required support parameters according to the model, 

click the "Auto Supports", and the generated support will be displayed as a linear structure.  

• Overhang Threshold: it specifies the model position that needs to be generated with 

supports according to the angle value (inclination of each part of the model) greater than 

any specified value, and the angle value ranges from 30 to 60 degrees. 
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• Post diameter: the diameter of the tree support, ranging from 1 to 6 mm; Base height: 

the height of the supporting base, ranging from 0 to 10 mm. 

• Base diameter: the diameter of the support base, ranging from 3-10 mm. 

• Pillar size: the pillar is composed of square columns, and the size refers to the single side 

length of the square columns, ranging from 1 to 8 mm. 

• Touch platform only: only the support in contact with the bottom plate is generated. 

3.6 New Project 

Click the "File->New Project" in the menu bar to create a new blank project. If there are unsaved 

changes in the original project, then you will be prompted if you need to save the changes. If you 

click "Yes", the changes will be saved. If you click "No", the changes are discarded. If you click 

"Cancel" or close the box, the new project will be canceled. 

 

 

3.7 Save Project 

After finishing the editing of the model, all the models in the scene can be saved in the following 

two ways: 

◆ Method 1: 

Click the "File->Save Project" in the menu bar to save the file as a project file with the suffix 

".fpp". In this type of file, all models (including supports) in the scene are independent. After 

reloading the file, the support information as well as the model position are the same as the 

configuration when saving. 

◆ Method 2:  

Click the "File->Save As" in the menu bar to save the scene as a project file (.fpp) or a file with the 

suffix ".stl", ".obj" and ".3mf". In the file with the suffix ".stl", ".obj" or ".3mf", the models 

(including tree supports) in the scene are not independent, but are merged into a new model; 

The models with linear supports in the scene are independent and the support part will not be 

saved, but the model part will be saved. After reloading the file, the model is in the same position 

as that of the saved configuration. 
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3.8 Print  

3.8.1 Choose Machine Type 

Before connecting the machine, click the  button at the bottom left corner, and select the 

current printer type by clicking on the machine name in the "Machine Type" expansion item. 

After connecting the machine, the software will automatically identify the type of the connected 

machine, and manual switching cannot be performed at this time. After selecting the machine 

type, the size of the machine frame in the scene will change, which will also affect the slicing 

results. 

Some Robo printers have multiple nozzle sizes available, and the nozzle size of the printer can be 

selected in the "Nozzle Size" expansion item. 

3.8.2 Connect Machine 

In order to connect the printer, we need to configure the printer (please refer to Section 3.9.1.1 

for the method). 

3.8.3 Print 

3.8.3.1 Generate Gcode File by FDM 3D Printer 

Before printing the model, the model needs to be sliced (slicing will generate the print file of the 

model, that is, the Gcode file). 

You can configure the slicing parameters and generate the slicing file by the following operations. 

◆ Step 1: Click the "Start Slicing" icon on the main interface of the software, and a 

dialog box for setting the slicing parameters will pop up. 

◆ Step 2: After setting the slicing parameters of the model, click the "Slice" button to 

start generating the Gcode file, which will be saved in the temporary directory. In 

this process, a status bar will be displayed at the bottom of the main screen, 

showing the progress of slicing the model and uploading the Gcode file. After 

slicing is started, the "Start Slicing" button on the main interface will become the 

"Stop Slicing" button, which can be clicked to interrupt slicing. 

◆ Step 3: After finishing slicing, "Slice Preview" and "Local Save" buttons will appear 

on the top of the main interface. Click the "Slice Preview" button to enter the 

interface of the slicing preview and observe the slicing results of the model file. 

Click the "Local Save" button to save the Gcode file locally or send the Gcode file 

directly to the printer for printing. 
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1) Slicing parameters in the basic mode 

 

◆ Nozzle Size: The default nozzle that came with your printer is selected by default. If 

multiple size nozzles are available for your Robo printer, there will be a dropdown 

where you can select a different size. 

◆ Material Type: Select the filament you are using and 1.75mm as the appropriate 

diameter of filament for Robo printers.  

◆ Raft: To improve bed adhesion, Enable a raft. This will print an extra couple of 

layers below your model which can be removed after printing. The purple in the 

image below is the raft.  

 

◆ Slice Profile: Three configuration scheme options (Standard/Fine/Fast) are 

available in the slicing configuration, and different schemes have been set up with 

different parameters.  
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a. Layer Height: It is the printing thickness of each layer when building the 

model. The smaller the thickness, the smoother the model surface, but the 

longer the printing time. 

b. Fill Density: It is for setting the amount of the internal filling.  

c. Print Speed: It is used to calculate the moving speed of the extruder during 

filament extrusion. The slower the speed, the higher the printing quality, 

but the longer the printing time.  

d. Shell Count: It is the number of paths used to build the model shell. The 

more paths, the thicker the wall of the model and the longer the print 

time.   

2) Slicing parameters in expert mode. 

Click the "Expert Mode" button in the basic mode interface to enter the configuration 

interface of expert mode slicing parameters. 

 

Move the mouse to a slicing parameter or pause on a parameter value text box, and a floating 

explanation will appear on certain parameters.  

◆ Printer 

1）Nozzle Size: The default nozzle that came with your printer is selected by 

default. If multiple size nozzles are available for your Robo printer, there will be 

a dropdown where you can select a different size. 

2）Material Type: Select the filament you are using and 1.75mm as the appropriate 

diameter of filament for Robo printers.  

3）Slice Profile: Three configuration scheme options (Standard/Fine/Fast) are 

available in the slicing configuration, and different schemes have been set up 

with different parameters.  

4）Extruder Temperature: It is the temperature of the extruder during printing. 

Check your printer and the filament settings to choose a proper temperature 

for your machine and the filament you plan on using.   

5）Platform Temperature: Proper platform temperature allows the model to stick 

to the build plate better and improves the warping problem for larger models.  

6）Temperature Control List: It is for setting the printing temperature for different 

layers. 

7）Control Module: Select the module of which the temperature needs to be 

controlled. After adding, select this function, and it will work when printing. 
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Note: Different temperatures will have a subtle effect on the printing effect. To get 

better printing results, users may need to make adjustments according to their 

own conditions. 

◆ General 

1) Layer Height: how thick each layer of the model is. Thicker layers print faster, but 

have less detail than thinner print layers.  

        a. Layer Height Mode 

1．Fixed Layer Height

 

2．Variable Layer Height: Select "Variable Layer Height" and you can enter 

the variable layer height editing interface. 

① button: Click this button to pop up the variable layer height 

edit dialog box, where you can add or delete the layer height corresponding 

to the specified height.   

② Model layer height schematic bar: Right-click the slider on the right 

side of the interface-> -> The variable layer height edit dialog box 

pops up. At the same time, the default added height is the height 

corresponding to the mouse clicking position, and the default deleted height 

is the closest added height to the mouse clicking position.   

③ Click the "OK" button to return to the expert mode interface.  

b. Layer height: It is the printing thickness of each layer when building the model. 

The smaller the thickness, the smoother the model surface, but the longer the 

printing time. 

            c. First Layer Height: When printing with a smaller layer height, the larger first 

layer height allows the model to stick better to the build plate. 

2) Speed 

a. Base Print Speed: It is the reference movement speed of the extruder during 

filament extrusion, taken as the reference value for the subsequent printing speed 

calculation. 
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b. Travel Speed: It is the movement speed of the extruder when there is no 

filament extrusion.  

c. Minimum Speed: It is the minimum movement speed of the extruder during 

filament extrusion. 

d. First Layer Maximum Speed: It is used to limit the printing speed of the first 

layer to allow the model to better adhere to the build plate. This parameter does 

not work when the raft function is enabled.  

e. First Layer Maximum Travel Speed: It is used to limit the travel speed of the first 

layer to allow the model to better adhere to the build plate. This parameter does 

not work when the raft function is enabled. 

f. Slow Down First Few Layers: Lower the printing speed of the first few layers to 

improve the printing success rate; For example, 3, 30mm/s means that the first 2-4 

layers are printed at a speed of 30 mm/s; The first layer is not controlled by this 

command, and this function does not work when it is set to 0.  

3) Retraction 

a. Retraction Length: It is the length for retracting the filament back to the nozzle 

before extruder traveling or switching to improve the filament leakage problem. 

b. Retraction Speed: The speed at which the extruder retracts the filament back 

into the nozzle. 

c. Extrusion Speed: The speed at which the extruder extrudes the filament out of 

the nozzle. 

d. Extra Restart Length: The compensation length of the extruded filament after 

retraction. 

 

e. Only Retract When Crossing Outline: It is used to reduce the number of times of 

retraction, but it is easy to leave filaments at the peak. Select "No" to avoid this 

problem. This function is only supported by the Robo E3 at the moment. 
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◆ Shells 

1) Thickness 

a. Shell Count: It is the number of paths used to build the model shell. The 

more paths, the thicker the wall of the model. 

b. Shell Thickness: The thickness of the shell of the model. 

c. Overlap Perimeter: The maximum width ratio of shell path overlapping 

allowed at thin wall. 

 

2) Speed 

a. Exterior Speed: The ratio of the printing speed of the outermost layer of the 

model shell relative to the reference speed.  

b. Exterior Maximum Speed: It is used to limit the printing speed of the 

outermost layer of the model shell. 

c. Visible Interior Speed: The ratio of the printing speed of the visible part of 

the inner layer of the model shell relative to the reference speed.  

d. Visible Interior Max Speed: The maximum printing speed of the visible inner 

ring. 

e. Invisible Interior Speed: The ratio of the printing speed of the invisible part 

of the inner layer of the model shell relative to the reference speed. 

3) Start Points 

a. Mode: It is used to set the rules for selecting the start point of the shell 

path. There are three start point modes: one is "closest to specific location", 

the other is "use random start points", and the other is "inner recess point". 

Closest to specific location: The start points of the shell paths of all layers are 

as close as possible to the specified coordinates to align the joint position. 

Use random start points: The start points of the shell are randomly distributed 

on the surface of the model to hide the joint position. 

Inner recess point: The inward-concave point is preferred as the start point, 

and the point closest to the specified position is used as the start point when 

there is no inward-concave point. 

b. X: X coordinate of the start point alignment position of the shell. 

c. Y: Y coordinate of the start point alignment position of the shell. 



 

26 

Copyright Boxlight 2024. All rights reserved. 

d. Permit optimizing start points: It allows the software to adjust the start 

point position as required, using a point other than "the point closest to the 

specific position" as the start point. It is recommended to select "No" when 

printing a vertically placed displacement model generated from an image.  

◆ Infill 

1) General 

a. Top Solid Layers: The number of layers using solid fill on the upper surface of 

the model.   

b. Bottom Solid Layers: The number of layers using solid fill on the lower 

surface of the model. 

c. Fill Density: It is used to set the compactness degree of the internal filling. 

d. Fill Pattern: It is used to set the shape of internal filling. 

• Hexagonal filling is with higher strength, 

• Linear filling prints faster,  

• Triangular filling prints slightly slower than linear filling, but the 

adhesion between layers is higher. 

• Three-dimensional filling is a three-dimensional spiral filling shape, 

which is generally used when the filling density is low. It is 

recommended to turn off the "Combine Infill" function when using 

this filling. 

e. Overlap Perimeter: The width ratio of the filling to the shell overlap path. 

f. Vase Mode: It is used to print single-layer models without joints. When this 

function is enabled, the number of shells is always 1, the filling density is 

always 0, and the number of top layers is 0 by default.    

2) Speed 

a. Solid Speed: The ratio of the model's top and bottom fill printing speed 

relative to the reference speed.  

b. Sparse Speed: The ratio of the printing speed of the internal filling of the 

model relative to the reference speed. 

3) Combine Infill 

a. Maximum Solid Combine: The filling areas overlapping between adjacent 

layers are merged to print together to increase the printing speed. After 

merging, the filling path will become thicker, but the thickness of the shell path 
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will remain unchanged. It is recommended that the height of the top/bottom 

cover should not exceed 0.2mm after merging. 

b. Maximum Sparse Combine Layers: The filling areas overlapping between 

adjacent layers are merged to print together to increase the printing speed. 

After merging, the filling path will become thicker, but the thickness of the 

shell path will remain unchanged. It is recommended that the height of 

interior filling should not exceed 0.36mm after merging. 

c. Combine Area Threshold: When the printing area of a certain layer is less 

than the specified threshold, the layer will not be merged and filled, in order 

to increase the printing time of the layer and ensure that the next layer can be 

printed after the filament cools down. 

4）Strength(en) Infill 

a. Interval Layers: Extra solid filling of some layers at each interval of a certain 

number of layers makes the model more solid, and "0" means it is not enabled. 

b. Solid Layers: The number of added layers for solid filling. 

c. Infill Density Control: It is used to add the layer control command of filling, 

conducive to strength enhancement and rational utilization of materials 

according to the needs of the model design; It is also used for the filling 

density layer control. The density items from the Start Layer to the End Layer 

are specially set. 

◆ Supports 

1) Supports Type 

① Tree: 

a. Speed: The ratio of tree support printing speed relative 

to the reference speed.  

b. Space to Model (X/Y): It is used to set the minimum 

clearance between the model and the support in the 

horizontal direction to facilitate the support removal. 

c. Shell Count: It is the number of paths used to build the 

tree support shell. The more paths, the thicker the wall of 

the tree support. 

d. Auto Setup Z Hop: Raise the extruder or lower the build 

plate when the extruder is traveling to avoid the tree 

support being knocked down by the extruder. 
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② Linear:  

a. Speed: The ratio of linear support printing speed 

relative to the reference speed. 

b. Space to Model (X/Y): It is used to set the minimum 

clearance between the model and the support in the 

horizontal direction to facilitate the support removal. 

c. Space to Model (Z): It is used to set the clearance 

between the model and the support in the vertical 

direction to facilitate the support removal. 

d. Space to Raft (Z): It is used to set the clearance 

between the raft and the support in the vertical direction 

to facilitate the support removal. 

e. Path Space: It is used to set the spacing between adjacent round-trip paths 

of the linear support. Smaller spacing provides better supporting effect, but it 

takes more printing time and makes removing the supports more challenging. 

f. Path Density: It is used to set the density of the support path. The higher the 

density, the more solid the support, but the longer the printing time and the 

more filament will be used. 

g. Support Thickness: The higher the thickness of the support, the more solid 

the support; the lower it is, the easier it is to remove the support. 

h. Top Solid Layers: The linear support top cover can improve the printing 

quality of the contact surface between the model and support, but it is not 

conducive to the support removal. 

i. Path Angle: The angle between the support path and the filling path of the 

first layer. 

j. Top Solid Density: It is used to set the density of the support path top cover. 

The higher the density, the more solid the support, but it is not conducive to 

the support removal. 

k. Horizontal Expansion: Expanding the support area in the horizontal direction 

can avoid the lack of support at the edge of the model. 

l. Print Outline: You can choose whether to print the outline of the linear 

support or not with this parameter option. Select "Yes" can avoid the problem 

of incomplete support area, and select "No" can facilitate the support removal.       
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◆ Raft 

1) General 

a. Enable Raft: Print a raft on the build plate before printing the model so that 

the model can stick to the build plate better. Select 'Yes' to use the raft and 

'No' to not use the raft. 

     

 No Raft or Brim Raft Brim (See Additions) 

b. Margin: The width of the raft extending outward from the first layer outline 

of the model.  

c. Space to Model (Z): It is used to set the clearance between the model and 

the raft in the vertical direction to facilitate the raft removal. 

d. Above Raft Maximum Speed: Limit the printing speed of the first layer above 

the raft to make the model stick to the raft better. 

e. Above Raft Extrusion Ratio: It is used to set the amount of the filament 

extrusion of the first layer above the raft. The more the filament extrusion, the 

better the printing quality of the first layer of the model, and the more difficult 

it is to remove the raft. 

2) Bottom layer 

a. Layer Height: The higher bottom layer height makes it easier for the raft 

to stick to the build plate. When the build plate temperature is higher, 

the thicker raft features better thermal insulation. 

b. Path Width: The wider path width makes it easier for the raft to stick to 

the build plate, but the wider path requires slower printing speed. 

c. Fill Density: The higher the filling density, the more firmly the raft and the 

build plate stick together, and the longer the printing time. 

d. Speed: With higher layer heights and larger path width, use a slower 

printing speed; otherwise it will not be able to extrude the filament in 

time. 
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3) Middle Layers 

a. Layer Height: The height of the transition layer in the middle of the raft. 

b. Layers: The number of transition layers in the middle of the raft. 

c. Path Width: The wider path width makes it easier for the raft to stick to 

the build plate, but the wider path requires slower printing speed. 

d. Fill Density: The higher the filling density, the more firmly the raft and the 

build plate stick together, and the longer the printing time. 

e. Speed: The lower the speed, the better it is for the transition layer and 

the bottom layer to stick together, and the longer the print time. 

 

4) Top Layers 

a. Layer Height: The layer height of the top layer of the raft. 

b. Layers: The number of the top layers of the raft. When the temperature 

of the build plate is more than 110ºC, it is recommended to add several 

layers to increase the thermal insulation of the raft. 

c. Path Width: The wider bottom layer path width makes it easier for the 

raft to stick to the build plate, but the wider path requires slower 

printing speed. 

d. Speed: The lower the speed, the better the smoothness of the top 

surface of the raft, and the longer the printing time. 

e. Angle Between Model: The angle between the filling path of the top 

layer of the raft and the model. 

◆ Additions 

1) Pre-extrusion 

a. Enable Pre-extrusion: Before starting to print the model, an extra 

filament extrusion path should be made to ensure smooth filament 

extrusion of the subsequent model printing. 

In the above images, the dark red line is the pre-extrusion. 

b. Margin: The spacing from the pre-extrusion path to the first layer 

outline of the model. 

c. Path Length: The length of pre-extruded filament. 

d. Speed: The printing speed of the pre-extrusion path. 
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2) Wall 

a. Enable Wall: Generates an additional wall structure all the way around 

the outside of the model. You will most likely not need to use this 

feature. 

b. Shell Count: It is the number of paths used to build the model shell. The 

more paths, the thicker the wall of the model, but the longer the 

printing time. 

c. Margin: It is used to set the spacing between the model and the wall. 

d. Speed: The wall printing speed. 

e. Generate Wall inside holes: If you select "Yes", the walls inside the 

model holes will be automatically eliminated when the walls are 

generated; If you select "No", the walls inside the model holes will not 

be eliminated. 

3) Brim 

a. Enable Brim: An additional circle of brim is printed around the bottom of 

the model and the extension part of the bottom of the model is fixed on 

the build plate to prevent it from overturning during printing. 

See “Raft” above for a sample image. 

b. Margin: It is the width of the brim. The greater the width, the more solid 

the brim, but the longer the printing time. 

c. Brim Layers: More brim layers can fix the model better, but are not 

conducive to the brim removal from the model. 

d. Speed: The brim printing speed. 

e. Generate Brim inside holes: If you select "No", the brim is no longer 

generated inside the holes, thus avoiding the problem that these brims 

are difficult to remove. 

4) Wiping Tower 

a. Speed: The wiping tower printing speed. 

◆ Cooling: 

1) Decelerate/Delay For Filament Cooling       

a. Deceleration Area Threshold: When the printing area of a layer is less 

than the specified threshold value, the printing speed of that layer is 

reduced to ensure sufficient filament cooling time. 
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b. Delay Area Threshold: When the printing area of a layer is less than the 

specified threshold value, the printer will delay printing after printing 

the layer to ensure sufficient filament cooling time, and 0 means that 

the printer will not delay printing for filament cooling. 

c. Maximum Delay Time: The maximum delay time for filament cooling. 

 

2) Cooling Fan Control 

a. Cooling Fan Control: It is used to set when to turn on the cooling fan, 

including "Always On", "Always Off", "ON (when raft bottom printed)", "ON 

(when to pre-set height)", "ON (while printing raft top)". 

b. Back Fan Status: It is used to set the status of the cooling fan on the back of 

the printer, including "Always On" and "Always Off". 

c. Back Fan Speed: It is used to set the rotating speed of the cooling fan on the 

back of the printer. 

 

d. Cooling Fan Default Speed: It is used to set the original rotating speed of the 

cooling fan of the printer. 

e. Cooling Fan Control List: Change the cooling fan speed after printing to the 

set height. 
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◆ Advanced 

1) Bridge 

a. Enable Bridge: Optimize the direction of the filament extrusion path in the 

overhanging area and shorten the path span of the filament to improve the 

printing effect of the overhanging part of the model. 

b. Bridge Area Threshold: When the area of the overhanging area is less than 

the specified threshold value, it is no longer treated as a bridge and the 

bridge function is not available. 

c. Speed: The ratio of the bridge printing speed relative to the reference speed. 

 

2) Extrusion Ratio 

a. Extrusion Ratio: It is used to adjust the amount of filament extrusion. 

b. First Layer Extrusion Ratio: It is used to adjust the proportional parameter for 

the filament extrusion of the first layer. 

 

3) Path 

a. Path Width: It is the width of the filament extrusion path. The default value is 

the diameter of the nozzle. 

b. Path Precision: When the model features too many mesh subdivisions, it 

determines the simplification degree of the filament extrusion path. The 

higher the value, the lower the precision of the filament extrusion path, but 

the higher the precision of the corresponding filament extrusion amount. 

 

4) Ironing 

a. Enable Ironing: After enabled, it will pass through the top surface again, but 

this time, very little filament is extruded, which means that the plastic on the 

top will be further melted to form a smoother surface, and the pressure in 

the nozzle will remain high, to ensure that the surface creases can also be 

filled with materials to guarantee details. 
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◆ Others    

1) Dimensional Adjustments 

a. Enable Adjustments: Adjust the printing path for offsetting printing errors. 

b. External Compensation: Adjust the size of the outer diameter of the model, 

with a positive number indicating size enlargement and a negative number 

indicating size reduction. 

c. Internal Compensation: Adjust the size of the inner diameter of the model, 

with a positive number indicating size enlargement and a negative number 

indicating size reduction. 

d. Z Compensation: Adjust the printing height of the model, with a positive 

number indicating increase and a negative number indicating decrease. 

 

2) Z Hop 

a. Z Hop Mode: Lift the extruder or lower the build plate when idling to prevent 

the extruder from hitting the model. 

b. Z Hop Height: The extruder-lifted height or the platform-lowered height when 

idling. 

c. Z Hop Minimum distance: When the idling distance is less than the specified 

value, Z lifting is not carried out. 
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3) Pause At Layers 

a. Pause Layers: Automatically pause printing after printing to the set height. 

Edit one or more height values to be paused, and the maximum pause height 

shall not exceed the model height.  

This is very useful when printing multi-color prints!

   

◆ Save As New 

After modifying the required parameters according to the user's requirements, it 

can be saved as a new preset for subsequent use. 

Modify the required parameters, click the "Save As New" button, and a name 

input box pops up. Fill in the name according to the your needs, and click the "OK" 

button to save the settings successfully. 

After doing so, in the 'Printer->Slice Configuration' list, there will be one more 

optional setting (the newly added pre-set is related to the currently selected 

machine type and will only show up when that printer is selected) 

◆ Remove 

The "Remove" function is only available for the presets newly added to the current 

machine type. Select a new scheme, click the "Remove" button and a prompt box 

for confirmation of deletion pops up. Click "Yes" to permanently delete the 

selected settings, and "No" to cancel the deletion of the selected preset. 

◆ Restore Defaults: Restore the modified parameter values to the default 

configuration. 
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◆ Save Configuration: When you modified a parameter value in a setting or 

performed "Restore Defaults" to the modified parameter, click the "Save 

Configuration" button to save it, and when this configuration is selected again it 

will still be the saved value. 

◆ Import/Export: After modifying the required parameters according to the user's 

requirements, save the current slicing parameters to a local file for subsequent 

use. 

When you need to export the configuration, click the "Export" button to save the 

current slicing parameter settings as a local .fcfg format file. 

When you need to import the configuration, click the "Import" button to import 

the slicing parameter configuration file in the .fcfg format into the configuration 

list, then there will be one more optional preset in the "Printer->Slice 

Configuration" list for that type of printer. 

 

3.8.3.2 Print Gcode File by FDM 3D Printer 

        1)  After the Gcode file is generated, you can send the Gcode file to the printer and 

start printing. 

◆ Step 1: After the model file is sliced or the saved Gcode file is loaded, the "Local 

Save" button will appear at the top of the main interface. 

◆ Step 2: Click the "Local Save->Send To Printer" and start printing. 

2)  Weight Estimation 

◆ Material Length: The filament length required to print the model. 

◆ Material Type: Different types of filaments can be selected for estimation, and 

"Material Density" can be changed manually when "Custom Material" is selected. 

◆ Material Density: The material density corresponds to the "Material Type". 

◆ Weight Estimation: The estimated material weight based on the length and 

density of the filament. 

The preview interface of Gcode file allows you to view the slicing results of the model. By 

left and right sliding the "Layers" and "Steps", you can control the number of display 

layers of the model, observe the structure of each layer of the model, the layer height and 

the printing speed. The upper right corner of the preview interface displays model 

printing information, including "Slice File Name", "Estimated Print Time", "Estimated Print 

Material" and "Weight Estimation". 
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Click the "▽" button to display more slice information of the model file. 

 

Click the "Local Save->Send To Printer" and start printing. Click the "Close Preview" 

button to exit the preview interface of the Gcode file. 

3.8.3.3 Pause and Stop Printing 

After printing is started, click the "Multi-Machine Control" button on the right side of the main 

interface or "Tools-> Multi-Machine Control" to enter the multi-machine control interface, which 

will display the current status of all connected printers, with the "Pause" and "Stop" buttons 

displayed at the bottom of the status bar of the current machine type. 

After pausing, you can still continue printing. After stopping, the printing is canceled and cannot 

be restarted from where it left off. 

Note: Pausing may affect the printing effect, so it is recommended not to use it when 

unnecessary. 
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3.9 Printer Operations 

3.9.1 Connect/Disconnect 

3.9.1.1 Connect 

The computer can be connected to multiple printers at the same time. There are two connection 

methods: 1. Automatic connection; 2. Wi-Fi/Ethernet connection. 

◆ Method 1: USB (Automatic) connection 

a. First, use the USB cable to connect the socket on the back of the printer to 

the computer. This USB cable option is only available on certain models. Your 

printer may not have it. 

b. Turn on the printer and open the RoboPrint software.  

c. Click the "Print->Connect Machine" or "Multi-Machine Control->Connect" in 

the menu bar, and select "Automatic Scan" as the connection method in the 

Connect Machine dialog box that pops up. The "Automatic Scan" connection 

mode will scan and display all machines that can be connected, including Wi-

Fi connections and USB cable connections. 

d. Click the  button next to the printer name to connect to the printer. 

Troubleshooting: If it doesn’t show up, click rescan. You should also try 

turning your printer off and back on. If the serial port still does not appear, it 

means that the driver of the software is not installed (usually, the driver will 

be installed automatically when installing the software). If such a situation 

occurs, you need to install the driver manually. Please refer to Section 3.8.3.1 

for the method. 

◆ Method 2: Wi-Fi connection 

There are two types: 

⚫ Type 1: Connect your computer to the 3D printer via wireless network. 

a. Turn on the printer and turn on the Wi-Fi (Tools-Setting-WIFI-WIFI ON). 

b. Turn on the wireless network selection, and select the network you 

would like. Enter the password and connect.  

Your printer and your computer MUST be on the same network for this to work! 

c. When you scan, your printer should show up and connect automatically.  
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d. If it doesn’t, you can also 

insert the IP address of your 

printer into the IP Address 

section of “Connect 

Machine.” The IP address 

location will vary from 

model to model of printer, but check your Info or About screen to find it 

on most models.  

• Type 2: Set the printer as a wireless discovery source and directly connect the 

computer to the 3D printer. 

a. Connect your printer to the internet using an ethernet cable and toggle 

ethernet on. 

b. Turn on the printer and turn on the Hotspot. On that screen, you can 

find the information for connecting to the hotspot. 

c. Connect your printer to the wireless network generated by the Hotspot. 

d. Click the "Print->Connect Machine" in the menu bar. Try automatic scan 

first. If that doesn’t work, go to IP Address and insert select Wi-Fi as the 

connection method, enter 10.10.100.254:8899 and then click the 

"Connect Machine" button. 

Note: A machine can only establish one connection. If the machine has been occupied by another 

software process, it is necessary to wait for the connection to be disconnected before establishing 

the connection again; If you use AP mode to connect the machine, the computer will not be able 

to access the Internet through the wireless network. 

 

3.9.1.2 Disconnect 

When one or more printers are connected, check any printer in the Multi-Machine Control 

interface and click the "Disconnect" button to disconnect the computer from this printer. 

Click the "Print->Disconnect All Connection" in the menu bar to disconnect the computer from all 

printers. 

 

3.9.1.3 Set As Current 

When the computer is connected to multiple printers at the same time, right-click on any printer 

after checking it in the Multi-Machine Control interface and select "Set As Current" in the pop-up 

menu to switch the operation interface to the interface corresponding to the currently selected 

printer. 
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3.9.1.4 Modify Printer Name 

Right-click on any printer after checking it in the Multi-Machine Control interface and select 

"Rename" in the pop-up menu and a dialog box to modify the printer name pops up. Click "OK" 

after modifying the name, and the printer name is modified successfully; Click the "Cancel" 

button and the printer name will not be modified. 

 

3.9.2 Control Panel 

When the computer is connected to the printer, click the "Tools->Control Panel" in the menu bar 

to open the control panel of the printer and perform the following operations in the panel. When 

selecting different machine types, the display settings on the control panel are different. You may 

not see all of the below settings depending on your machine. 

◆ Jog Controls 

a. Jog Mode: Select the moving distance of the extruder or build plate (that is, the moving 

distance of the extruder or build plate in a single direction). 

b. Six blue direction buttons on the left: These buttons correspond to the movements on 

the X, Y and Z axes respectively. The X and Y axes are used to control the horizontal 

position of the extruder, and the Z axis is used to control the up and down position of the 

build plate. 

Press the X- button, and the extruder will move to the left for a specified distance; Press 

the X+ button, and the extruder will move to the right for a specified distance; Press Y- 

button, and the extruder will move to the front of the printer for a specified distance; 

Press the Y+ button, and the extruder will move to the back of the printer for a specified 

distance; Press the Z- button, and the build plate will move upward for a specified 

distance; Press the Z+ button, and the build plate will move downward for a specified 

distance (the specified distance is the moving distance set in the "Jog Mode"). 
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c. Stop: Click this button to abort the current movement operation. 

d. XYZ coordinate frame on the right: It displays the current positions of the extruder and 

build plate. 

e. Make current position zero: Click this button to set the current position of the extruder 

and build plate as the home position in any state. 

f. Center X/Y/Z: Click each button to make the extruder and build plate return to the 

original position set last time in the corresponding direction. 

g. X/Y Speed and Z Speed: It is used to set the moving speed of the extruder and the build 

plate. 

 

◆ Limit Switch 

For printer protection, there are three limit switches in the printer to control the limiting 

position of movement. These three switches are the maximum limit switches in X/Y/Z 

direction, and there are the following two switch states for them: 

a. Not Triggered Status: When the extruder or build plate does not move to the limiting 

position of the printer, the motion limit switch of the X/Y/Z axis of the printer is not 

triggered, and the switch state is "Not Triggered". 

b. Triggered Status: When the extruder or build plate has moved to the limiting position 

of the printer, the maximum or minimum switch of X/Y/Z axis of the printer will be 

triggered, and the switch state will change to "Triggered" state according to different 

machine type settings. 
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◆ Cooling Fan Controls  

It is used to set whether the fan on the extruder side is running or not. Click the "Turn on" 

button to set the fan to run; Click the "Turn off" button to set the fan not to run. 

◆ Filament Detect(ion) 

It is used to check whether the filament is loaded. 

◆ Servo Controls 

It is used to control the on or off state of the servo. 

◆ Stepper Motor Controls  

It is used to set whether to turn on the stepper motor. Click the "Enable" button, the motor 

enters the locking state and the position of the extruder or build plate cannot be changed 

manually; Click the "Disable" button to allow manual changes to the position of the extruder 

and build plate. 

◆  LED Color 

The luminous color of the printer's built-in light bar can be changed with the "LED Color" 

button.  

◆  Extruder Controls 

The Extruder Controls interface is generally used for filament feeding and withdrawing 

operations. By setting the value of the "Motor Speed", it can be used to control the rotation 

speed of the filament feeding roll; By setting the value of the "Extrude Duration", it can be 

used to control the rotation time of the motor. Generally, it is recommended that the user 

select an option with a duration of 60 seconds. 

 

Before the motor rotates, the filament must be melted in the extruder, so please wait for 

the extruder temperature to reach the printing temperature corresponding to the filament 

before performing rotating operation. If ABS filament is used, the extruder temperature 

should reach 220℃. If PLA filament is used, the extruder temperature should reach 200℃.  

After reaching the target extruder temperature, you can click the "Forward/Reverse" button 

to control the filament feeding and withdrawing. In addition, if you need to stop filament 

feeding and withdrawing, you can click the "Stop" button. 

◆  Temperature Controls  

Enter the desired temperature in the box on the left, click the "Apply" button, and the 

printer will automatically start heating the corresponding part, while the right side shows 

the current actual temperature of the corresponding part. After starting heating, the curve 
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in the temperature icon below will start to change, with different colors corresponding to 

different temperatures of each part. 

Note: In actual operation, if both the extruder and build plate need to be heated, the printer 

will heat the extruder after the build plate is heated. 

3.9.3 Machine Information   

With the computer connected to the printer, click the "Tools->Machine Information" in the menu 

bar to view the information about the machine, including machine type, machine name, 

firmware version, etc. 

3.9.4 Driver Installation 

The driver installation method is as follows: 

◆ Step 1: Open the root directory of the software.  

(for example, C:\Program Files\Boxlight\RoboPrint) 

◆ Step 2: Open the driver folder under the root directory, find the driver software, and 

click to install (there are two installation packages: dpinst_amd64.exe corresponding to 

64-bit system, dpinst_x86.exe corresponding to 32-bit system, please choose according 

to your needs). 

3.9.5 Multi-Machine Control 

Click the "Tools->Multi-Machine Control" in the menu bar, entering the multi-machine 

control interface. 

 

◆ Connect: The same function as "Print->Connect Machine". The connected machine will 

be displayed in the group. 

◆ Send GCode: Send the Gcode file to the machine with the same type as the current 

machine type, and no Gcode files should be sent to the machine with different type 

from the current machine type. 
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◆ Continue: Send a "continue printing" command to all printers that have been checked 

and are in the pause-printing status. 

◆ Pause: Send a "pause printing" command to all printers that have been checked and are 

in the printing status. 

◆ Abort: Send an "abort printing" command to all printers that have been checked and 

are in the printing status. 

◆ Disconnect: Disconnect all printers that have been checked. 

◆ Move To: Select "Move To" in the pop-up menu to move all checked printers to the 

designated group or to a new group. 

◆ Select All: Check and select all printers in the current group. 

 

When the printer enters the printing state, the current extruder temperature, platform 

temperature, target temperature and printing progress of the printer will be displayed in the 

basic information; The extruder temperature, platform temperature and printing speed can be 

set in the settings. 

  

3.10 Others  

3.10.1 Preferences 

Click the "File-> Preferences" in the menu bar to select the interface language and whether to 

check for updates after start-up. 
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◆ Language 

The interface language of the software currently supports the following fourteen languages: 

English, Japanese, Simplified Chinese, Traditional Chinese, French, German, Arabic, Spanish, 

Czech, Turkish, Portuguese, Korean, Polish and Russian. Select the desired language according to 

the user's needs. 

After selecting the language, click the "OK" button. 

◆ Font Size 

The font size is relative to the monitor size. Users are free to change the font size according to 

custom preference. 

◆ Color Theme 

The user can switch the light/dark mode of the display freely.  

◆ Auto layout newly-imported model 

It is used to set the placement position of the model when loading the model. If "Yes" is selected 

in the "Auto layout newly-imported model", the first model loaded will be automatically centered 

and placed on the platform when loaded. If multiple items are imported, they will auto-layout to 

not overlap with each other. 

If "No" is selected, the model will be placed according to its original location when loaded. 

◆ Check for Updates after start-up  

It is used to set whether to start the online automatic update function. If "Yes" is selected in the 

"Check for Updates after start-up", a new version of the software can be automatically detected 

online every time the software is started. Once a new version is found, the user will be prompted 

to download and install the updated version. 

3.10.2 Help Contents 

Click the "Help->Help Contents" in the menu bar to view the help manual online. 

3.10.3 Feedback 

Click the "Help->Feedback" in the menu bar, where users can give feedback and raise questions 

or problems. 

3.10.4 Check for Updates 

There are two ways to update the software version: 
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◆ Automatic Update 

Turn on the "Check for Updates after start-up" option and the software version will be 

automatically updated online. Click the "Skip this version" button to skip the update. Please refer 

to Section 3.9.1 for details. 

◆ Manual Update  

Click the "Help->Check for Updates" in the menu bar to check if there is an updated software 

version available online. If an updated software version is detected, a new version update log will 

pop up, and users can choose to download and install the updated version or close the prompt 

according to their needs. 

Note: Please refer to Section 2.1 to 2.2 for the download and installation process of the software. 

 

3.10.5 About RoboPrint 

Click the "Tools->About RoboPrint" in the menu bar, it will display the information of the 

software, including the current software version, copyright, and update logs (change logs). 

 

3.10.6 Model database 

Users can now import frequently-used files into the model database by themselves. After 

imported, those files can be easily called when relaunching the slicing software. Click to add to 

the base plate, the model will be imported into the platform, then you may proceed to slicing. 

 

 

 


